SaaS Pricing Service Outage

Incident Report for InsideRx

Resolved

Functionality is restored to SaaS Pricing By NPI. Everything is working as expected.
Posted Jul 02, 2026 - 09:02 CDT

Investigating

We are experience major issues with our SaaS Pricing Service. No other services are impacted. The team is investigating.
Posted Jul 02, 2026 - 08:37 CDT
This incident affected: APIs (Pricing By NPI API, Pricing By Region API).